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About This Manual

This manual provides an overview of the LabVIEW Report Generation
Toolkit for Microsoft Office. It contains information about generating
reports in Microsoft Word (hereafter known as Word) and Microsoft Excel
(hereafter known as Excel) formats from LabVIEW. You do not have to be
proficient in Word or Excel to use this toolkit.

Conventions
The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click in the software, such
as menu items and dialog box options. Bold text also denotes parameter
names, controls and buttons on the front panel, dialog boxes, sections of
dialog boxes, menu names, and palette names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction
to a key concept. This font also denotes text that is a placeholder for a word
or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames and extensions, and code excerpts.

Related Documentation
The following documents contain information that you might find helpful
as you read this manual:

• LabVIEW Report Generation Toolkit for Microsoft Office Help,
available by selecting Help»Report Generation Toolkit

• LabVIEW User Manual
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• LabVIEW Help, available by selecting Help»Contents and Index

• Microsoft Visual Basic Help, available on any version of the Microsoft
Office CD
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1
Overview of the Report
Generation Toolkit for
Microsoft Office

Reports are an essential part of a professional application. They must
contain all the information that the user wants. In addition, reports must
look professional and be carefully formatted.

Microsoft Word (hereafter known as Word) and Microsoft Excel (hereafter
known as Excel) are powerful report writers. Most users already know how
to work with these tools. The applications’ complete ActiveX interface
combined with LabVIEW ActiveX client capabilities make them
appropriate options for adding report generation functionalities to
LabVIEW applications.

The complexity of the ActiveX interface, however, makes the development
of custom applications difficult. The Report Generation Toolkit isolates the
user from the object model by providing a set of flexible and easy-to-use
VIs. The integration of the Word and Excel report formats into the
LabVIEW Report Generation VIs makes report generation even easier.

Functions Overview
The Report Generation Toolkit is integrated into the Functions»Report
Generation palette that is part of LabVIEW. The toolkit modifies the
Report Generation VIs to support Word and Excel formats as well as the
standard and HTML report formats. The toolkit also includes two new
subpalettes on the Report Generation palette that give the user access to
lower-level Word- and Excel-specific VIs.

The toolkit contains the following three categories of VIs:

• High-level report generation VIs—These are similar to the Report
Generation VIs shipped with LabVIEW. The only difference is that
they support two additional report types, Word and Excel.
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• Word-specific VIs—The Functions»Report Generation»Word
Specific VIs palette contains four high-level VIs and four subpalettes.
The high-level VIs perform basic operations. VIs in the subpalettes
perform the following advanced tasks:

– General subpalette—document management, search and replace,
page numbering

– Tables subpalette—editing and formatting Word tables

– Graphs and Pictures subpalette—editing and formatting
pictures and Microsoft graphs

– Advanced subpalette—formatting and macro functions

• Excel-specific VIs—The Functions»Report Generation»Excel
Specific VIs palette contains four high-level VIs and four subpalettes.
The high-level VIs perform basic operations. VIs in the subpalettes
perform the following advanced tasks:

– General subpalette—document management, search and replace,
data retrieval

– Format subpalette—spreadsheet and cell formatting

– Graphs and Pictures subpalette—editing and formatting of
pictures and Microsoft graphs

– Advanced subpalette—macro functions and miscellaneous
operations
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2
Creating Reports with
Microsoft Word and Excel

The Report Generation Toolkit includes VIs that work directly with
Microsoft Word (hereafter known as Word) and Microsoft Excel (hereafter
known as Excel). The VIs appear on the Functions»Report Generation»
Word Specific VIs and the Functions»Report Generation»
Excel Specific VIs palettes.You can use the application-specific VIs
to create and edit Word documents and Excel worksheets, and to format
text, tables, and pictures into Word- and Excel-based reports.

Creating New Reports
You can use the New Report VI located on the Functions»
Report Generation palette to create a Word- or Excel-based report.

Complete the following steps to generate a new report:

1. Place the New Report VI on the block diagram.

2. Set the report type parameter either to Word or Excel.

3. Set the window state parameter to minimized. This will accelerate the
report generation process.

4. When you run the New Report VI, it automatically creates a Word
document or Excel spreadsheet.

5. You can edit, save, and print the new report with the high-level
report generation VIs on the Functions»Report Generation palette
and with the application-specific VIs. For Word documents, use
the Word-specific VIs located on the Functions»
Report Generation»Word Specific VIs palette. For Excel
worksheets, use the Excel-specific VIs located on the
Functions»Report Generation»Excel Specific VIs palette.

6. Use the Word Bring to Front VI or the Excel Bring to Front VI to make
the report visible.

Report Generation Toolkit VIs can handle several Word documents at
the same time, or several Excel worksheets in the same workbook.
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The Word Add Document VI allows you to add new or existing documents
to the documents collection, and the Excel Add Worksheet VI allows you
to add new or existing worksheets to the worksheets collection. The Word
Get Document VI allows you to switch from one document to the other,
which you can use to edit a report consisting of several documents. The
Excel Get Worksheet VI allows you to switch from one worksheet to the
other within the same workbook, which you can use to edit a report
consisting of several worksheets.

By default, Report Generation Toolkit VIs used with Excel apply to the first
worksheet of a new workbook or to the worksheet that was active when you
last saved the workbook.

Inserting and Retrieving Data
The Report Generation Toolkit VIs allow you to insert new data, such as
text, tables, pictures, and graphs, into Word documents and Excel
worksheets.

Inserting Data into Word Documents
You can use both high-level report generation VIs located on the
Functions»Report Generation palette and Word-specific VIs located on
the Functions»Report Generation»Word Specific VIs palette to insert
text, tables, pictures from files, graphs, and objects into a Word document.
By default, Report Generation VIs perform the insertion at the end of a
document.

You also can insert data into bookmarks in a Word template. Refer to
Chapter 3, Creating Reports from Existing Templates, for more
information about templates.

Inserting Text
You can use the Append Report Text VI located on the Functions»Report
Generation palette to insert text at the end of the report. You also can use
the Append Report Text VI to insert text into an existing template by
specifying a bookmark in the MS Office parameters cluster. Refer to
Chapter 3, Creating Reports from Existing Templates, for more
information about bookmarks.

The Word Easy Title and Word Easy Text VIs located on the Functions»
Report Generation»Word Specific VIs palette also perform text insertion
tasks. The Word Easy Text VI does not support bookmarks. Use the
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Word Easy Text VI to access formatting attributes such as fonts,
background color, text alignment, and line style.

Inserting Data into Excel Worksheets
You can use high-level report generation VIs such as the Append Text to
Report VI or the Append Table to Report VI located on the Functions»
Report Generation palette, to insert strings, numbers, images, and arrays
of numbers or strings into an active Excel worksheet. The VIs that can
perform insertion tasks include a parameter called MS Office parameters
that lets you specify the row and column indexes or the name of the cell or
range where the insertion takes place.

The Excel Get Data VI located on the Functions»Report Generation»
Excel Specific VIs palette can retrieve data from an Excel worksheet. The
Excel Get Data VI retrieves scalars or arrays of strings or numbers. The
data type parameter specifies the type of data that you expect the VI to
return. The Excel Get Data VI returns the contents of an entire worksheet
if you do not wire the start and end clusters, the contents of a single cell if
you wire only the start cluster, or the contents of a range of cells if you wire
both the start and end clusters. To return an entire row, set the column
element of the start cluster to –1. To return an entire column, set the
row element of the start cluster to –1.

Note The Excel Get Data VI is polymorphic. To ensure that the VI does not return any
errors, the data type connected to the VI must be compatible with the content of the
worksheet. For example, the Excel Get Data VI returns an error if you ask for a array of
numbers and the worksheet contains strings. Refer to Appendix B, Polymorphic Functions,
of the LabVIEW User Manual for more information about polymorphic VIs.

Working with Tables in Word
The Report Generation Toolkit VIs are capable of inserting, formatting,
and editing tables in Word documents. All the tables included in a single
Word document represent the document table collection.

The Append Table to Report VI located on the Functions»Report
Generation palette and the Word Easy Table VI located on the
Functions»Report Generation»Word Specific VIs palette both can
insert tables into a document.

Use the Word-specific VIs located on the Functions»Report
Generation»Word Specific VIs»Tables palette to edit or format any
members of the table collection. By default, Table VIs apply to the last
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member of the table collection. However, you can apply a Table VI to any
member of the collection by specifying a table in the table index parameter.

Note Word tables support a maximum of 63 columns.

The Word Edit Cell VI can write new values into an existing table. Because
this VI is polymorphic, you can insert scalars or arrays of strings or
numbers. Refer to Appendix B, Polymorphic Functions, of the LabVIEW
User Manual for more information about polymorphic VIs.

If you specify a scalar value, the Word Edit Cell VI inserts the value into a
cell set by the row and column elements of the start cluster. If the value
that you specify is an array, the VI inserts the value starting from a cell set
by the start cluster.

You also can use the Word Edit Cell VI to insert an image into a cell. Set
the polymorphic VI to accept a file path in the value parameter instead of
a scalar or array.

Use the Word Format Cell VI, Word Format Table VI, and Word Table
Borders and Shading VI to set format attributes such as font, alignment, and
shading for existing tables. These Table VIs can format individual cells,
rows, columns, or entire tables, depending on the input parameter
configuration. Refer to the LabVIEW Report Generation Toolkit for
Microsoft Office Help for more information about these VIs.

When using Table VIs, the following guidelines apply:

• If neither start nor end are wired, the VI formats the entire table.

• If start is wired but end is unwired, the VI formats the unique cell, row,
or column specified by start. If neither row nor column are equal to
–1, the VI formats the corresponding cell. If row is equal to –1, the VI
formats the entire column. If column is equal to –1, the VI formats the
entire row.

• If both start and end are wired, the VI formats the range of cells
between start and end.

Use the Word Set Table Dimension VI to set the dimensions of the
document tables. You can specify the row height and the column width
individually either in inches or centimeters. Use the Word Merge Cells VI
and the Word Insert Row-Column-Cell VI to merge table cells or to insert
rows, columns, or cells into an existing table.
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The VI in the following illustration creates a new Word document, inserts
a table of numbers, and sets the table alignment to left.

The VI in the following illustration creates a new document, inserts a table
of numbers, and sets the cell font style to bold if the value is greater
than 0.5.

Working with Images
The Report Generation Toolkit includes VIs that can insert, format, and
edit images and graphs within Word and Excel reports. For Word-based
reports, use the VIs located on the Functions»Report Generation»Word
Specific VIs»Graphs and Pictures palette. For Excel-based reports, use
the VIs located on the Functions»Report Generation»Excel Specific
VIs»Graphs and Pictures palette.

Refer to Chapter 4, Working with Graphs, for more information about how
to use graphs in Word and Excel reports.
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Inserting and Formatting Images in Word
You can use the Report Generation VIs located on the Functions»Report
Generation palette to insert images into a Word document. The Append
Image to Report VI, the Append Front Panel Image to Report VI, and the
Append Control Image to Report VI can perform image insertion tasks.

All images included in a document are part of the document Inlineshapes
collection. The Inlineshapes collection also contains graphs, OLE objects,
and lines.

By default, the Append Image to Report, Append Front Panel Image to
Report, and Append Control Image to Report VIs insert images at the end
of a document. You also can insert images in a template bookmark. Refer
to Chapter 3, Creating Reports from Existing Templates, for more
information about templates and bookmarks.

You can use the Word-specific Graph and Picture VIs located on the
Functions»Report Generation»Word Specific VIs»Graphs and
Pictures palette to edit images and graphs in a Word document.

The Word Format Picture VI can modify the size, color, and scale of all
images in the Inlineshapes collection. By default, the Word Format Picture
VI applies to the last member of the Inlineshapes collection. You can apply
the VI to any member of the collection, however, by specifying an image
with the picture index parameter. You can select either the metric
(centimeters) or English (inches) measurement system for the size
parameters.

The VI in the following illustration creates a new document, inserts a
picture from a file, and uses the Word Format Picture VI to change the
picture color to black and white.

Inserting and Formatting Images in Excel
You can use the Append Image to Report VI, the Append Front Panel
Image to Report VI, and the Append Control Image to Report VI located
on the Functions»Report Generation palette to insert images into
an Excel worksheet. Use the MS Office parameters cluster to select
the cell from which you want to insert the picture.
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All the images added to a worksheet are part of the worksheet Shapes
collection. The Shapes collection also contains graphs and OLE objects.

You also can insert images starting from a named range. Refer to Chapter 3,
Creating Reports from Existing Templates, for more information about
named ranges.

The Excel Format Picture VI located on the Functions»Report
Generation»Excel Specific VIs»Graphs and Pictures palette can modify
the size, color, or scale of images in the Shapes collection. By default, the
Excel Format Picture VI applies to the last member of the Shapes
collection. You can apply the VI to any member of the collection, however,
by specifying an image with the picture index parameter. You can select
either the metric (centimeters) or English (inches) measurement system for
the size parameters.

The Shapes collection is relative to worksheets, not to workbooks. When
you create or activate a worksheet, subsequent Graph and Picture VIs apply
to the Shapes collection in the new worksheet.

The VI in the following illustration creates an Excel workbook, inserts a
picture from a file into the top left corner of the first spreadsheet, and sets
the scale of the picture to 0.5.

Formatting Reports in Word and Excel
You can use both Word-specific and Excel-specific VIs to format reports,
including font, alignment, and shading attributes. For a Word-based report,
use the VIs related to formatting located on the Functions»Report
Generation»Word Specific VIs»Advanced palette. For an Excel-based
report, use the Excel Format VIs located on the Functions»Report
Generation»Excel Specific VIs»Format palette.
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Formatting Word-based Reports
The Word-specific Advanced VIs located on the Functions»Report
Generation»Word Specific VIs»Advanced palette provide most of the
Word formatting functionalities available in the Report Generation Toolkit.

The Word Format Text VI can set the font attributes of sections of a
document. The Word Format Borders and Word Format Paragraph VIs can
set the shading, border, and paragraph attributes.

You can apply the Advanced VIs related to formatting either to an entire
document or to a specific section of the document. To format an entire
document, use the default values for the start and end input of the
formatting VIs. To format a custom range in a document, use the start and
end inputs to specify the positions of the first and last characters of the
range. Send the start out and end out output values from the report
generation VIs that are related to insertion to the start and end input values
of the formatting VIs.

The VI in the following illustration creates a new Word document, inserts
text and a picture into the document, and sets the alignment of the text and
picture to centered. The start index of the Append Image to Report and
Word Format Paragraph VIs is retrieved from the start out output of
Append Report Text VI. The end index of the Word Format Paragraph VI
is retrieved from the end out output of the Append Image to Report VI.

Note Paragraph, shading, and borders parameters are clusters that contain a large number
of elements, and therefore can use a large amount of block diagram space. To conserve
space on the block diagram, you can use the Indent and Spacing Constant and the Borders
and Shading Constant located on the Functions»Report Generation»Word Specific
VIs»Advanced»Constants palette with the Bundle by Name function located on the
Functions»Cluster palette as shown in the previous illustration.
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Formatting Excel-based Reports
You can use the Excel Set Cell Font VI, the Excel Set Cell Alignment VI,
and the Excel Set Cell Color and Border VI located on the Functions»
Report Generation»Excel Specific VIs»Format palette to set formatting
attributes in a worksheet. These VIs can format individual cells or an entire
worksheet, depending on how you set the start and end parameters.

The following guidelines apply to Format VIs:

• If neither start nor end are wired, the VI formats the entire used
section of the current worksheet.

• If start is wired but end is not wired, the VI formats the unique cell,
row, or column specified by start. If neither row nor column are equal
to –1, the VI formats the corresponding cell. If row is equal to –1, the
VI formats the entire column. If column is equal to –1, the VI formats
the entire row.

• If both start and end are wired, the VI formats the range of cells
between start and end.

The Excel Set Format VI can set the number format of cells in a worksheet.
Number formats customize the way Excel displays numbers, dates, times,
and strings. Refer to your Excel documentation for more information about
Excel format types.

The VI in the following illustration creates a new workbook, inserts an
array of numbers with header strings, and sets the background color of the
header to light green.
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The VI in the following illustration creates a new workbook, inserts an
array of numbers, and formats the cells so that numbers lower than 0.5
display in blue and numbers greater than 0.5 display in red.

Using Advanced VIs in Reports
The Report Generation Toolkit includes VIs that you can use for advanced
tasks in Word documents and Excel spreadsheets. For Word-based reports,
use the VIs located on the Functions»Report Generation»Word Specific
VIs»Advanced palette. For Excel-based reports, use the VIs located on the
Functions»Report Generation»Excel Specific VIs»Advanced palette.

Word Advanced VIs
The Functions»Report Generation»Word Specific VIs»Advanced
palette contains a set of VIs that access various advanced Word features.

You can use the Word Insert Object VI to exchange data between Word and
Excel. You can embed an Excel table into a Word document or insert any
file into a Word document. If the file does not correspond to a Microsoft
Office object, the Word Insert Object VI does not embed the object but
instead creates a link to the file containing the object.

The Word Send Document VI can email Word reports automatically to a list
of recipients.

Visual Basic Macros
The Functions»Report Generation»Word Specific VIs»Advanced»
Macros palette contains VIs that can run Microsoft Visual Basic macros
from LabVIEW. Refer to Chapter 5, Executing VBA (Visual Basic) Macros
from LabVIEW, for more information about macros.
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Excel Advanced VIs
The Functions»Report Generation»Excel Specific VIs»Advanced
palette contains a set of VIs that can access various advanced Excel
features.

You can use the Excel Rename Worksheet VI to give worksheets names that
you choose.

You can use the Excel Insert Object VI to exchange data between Word and
Excel. You can embed a Word document into an Excel worksheet or insert
any file into an Excel worksheet. If the file does not correspond to a
Microsoft Office object, the Excel Insert Object VI does not embed the
object but instead creates a link to the file containing the object.

The Excel Send Document VI can email Excel reports automatically to a
list of recipients.

You can use the Excel Sort Data VI and the Excel Insert Formula VI to
analyze data written in a worksheet. The Excel Sort Data VI sorts a
particular range of cells in ascending or descending order, either
horizontally or vertically. The Excel Insert Formula VI inserts formulas
into the worksheet by specifying a cell position and the formula string.
Refer to your Excel documentation for more information about formulas.

Visual Basic Macros
The Functions»Report Generation»Excel Specific VIs»Advanced»
Macros palette contains VIs that can run Visual Basic macros from
LabVIEW. Refer to Chapter 5, Executing VBA (Visual Basic) Macros from
LabVIEW, for more information about macros.
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3
Creating Reports from Existing
Templates

Generating complex and highly formatted reports is a time-consuming
process. The best way to increase productivity is to create a report template
containing components that are common to all reports and placeholders for
the data. After you save this template, you can generate reports by opening
the report template, inserting data into the placeholders, and displaying,
printing, or saving the resulting report.

Both Microsoft Word (hereafter known as Word) and Microsoft Excel
(hereafter known as Excel) provide ways to insert placeholders into
documents and worksheets and to save reusable templates. In Word, the
easiest way to define placeholders is to use bookmarks. In Excel, the easiest
way to define placeholders is to use named ranges.

Using Bookmarks in Word
You can use bookmarks to insert text, numbers, tables, or pictures into a
template. Complete the following steps to define a bookmark in your report
template.

1. In Word, open your report template. Place the cursor in the location
where you want the new bookmark to be.

2. Select Insert»Bookmark.
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3. Type the bookmark name you want to use and click the Add button
as shown in the following dialog box. Use meaningful names to
remember the significance of the bookmarks in the template.

When editing your report template, you can display bookmarks by selecting
Tools»Options in Word to open the Options dialog box. Click the View
tab and select Bookmarks.

The VIs that can perform insertion tasks all include the MS Office
parameters cluster, which lets you specify the bookmark from which the
insertion is performed. If you do not specify a bookmark, the insertion is
automatically performed at the end of the document.

You also can send data to a preformatted table in your template with the
Word Edit Cell VI. This VI can update either individual cells or a complete
range. Use the start parameter to specify the location of the cell or range to
update. Use the table index parameter to specify the location of the table
to update. A value of n in the table index parameter represents the (n + 1)th

table of the current document. The default value of –1 represents the last
table of the document.

Templates can include empty graphs you can update with the Word Update
Graph VI. Refer to Chapter 4, Working with Graphs, for more information
about graphs.
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The VI in the following illustration opens a template, updates the date and
time bookmarks with new data, sends values to the last table of the
template, and prints the resulting report.

Using Named Ranges in Excel
You can define a named range in Excel to insert text, numbers, tables, or
pictures into a template. Complete the following steps to define a named
range in your report template.

1. In Excel, open your report template. Select the cell or the range of cells
that you want to include in the named range.

2. Select Insert»Name»Define.

3. Type the name you want to use for the named range and click the Add
button as shown in the following dialog box. Use meaningful names to
remember the significance of the named ranges in the template.
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The VIs that can perform insertion tasks all include the MS Office
parameters cluster, which lets you specify the named range from which
the insertion is performed. If you do not specify a named range, the
insertion is performed from the cell defined by the position cluster.

The VI in the following illustration opens an existing report template,
updates the date and time ranges with new values, updates a table in the
template with new values, and saves the report.
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4
Working with Graphs

This chapter explains how to use the Report Generation Toolkit to insert,
format, and update graphs from the Microsoft Graph application into
Microsoft Word (hereafter known as Word) documents or Microsoft Excel
(hereafter known as Excel) worksheets. The Graph and Picture VIs in the
Report Generation Toolkit provide an interface to the Microsoft Graph
application, which is part of the Microsoft Office package. You must install
Microsoft Graph on your system to use these VIs.

Inserting a New Graph
Use the Word Insert Graph VI or the Excel Insert Graph VI to insert a new
graph into the current document or worksheet. You must send data to the
graph as a 2D array of numbers. You can send row and column headers,
or values and categories, as 1D arrays of strings. Graphs can hold up to
4000 rows and 4000 columns, and can display up to 256 data series.

When you format a graph, remember that graphs are members either of an
Inlineshapes collection in a Word document or a Shapes collection in an
Excel worksheet. Each graph in one of these collections accounts for one
index value. If your report contains two pictures followed by one graph, the
index value representing the graph is 2 and the index representing the first
picture is 0.

Format images and graphs immediately after inserting them into the
document or worksheet to avoid confusion with the collection indexes. By
default, VIs that are related to formatting apply to the last member added to
the document or worksheet.
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The Word Insert Graph VI and the Excel Insert Graph VI support all the
graph types provided by Microsoft Graph. The following table explains the
most commonly used graph types.

Graph Type Description

XY (Scatter) An xy (scatter) graph shows the relationship or degree of a relationship
between the numbers in several graph data series, or plots two groups of
numbers as one series of xy coordinates. The xy graph shows uneven
intervals of data. The arrangement of the data on the worksheet is very
important when creating an xy graph. Data must be arranged with the
x values in one row or column, followed by one or more corresponding
y values in the adjacent rows or columns.

Note: Only xy graphs have the ability to scale both the x and y axes.

Line Line graphs show trends or changes in data over a period of time at even
intervals. Although line graphs are similar to area graphs, line graphs
emphasize time flow and the rate of change rather than the amount of
change or magnitude of values.

Column Column graphs show variation over a period of time or illustrate
comparisons between items. Stacked and 100-percent stacked column
graphs show relationships to a whole. Although column graphs are similar
to bar graphs, column graphs organize categories horizontally and values
vertically.

Bar Bar graphs show individual figures at a specific time or illustrate
comparisons between items. Stacked and 100-percent stacked bar graphs
show relationships to a whole. Although bar graphs are similar to column
graphs, bar graphs organize categories vertically and values horizontally.
This type of organization places more emphasis on comparisons and less
emphasis on time.

Three-dimensional
Surface

Three-dimensional surface graphs show a view that resembles a sheet
stretched over a three-dimensional column graph. Surface graphs are useful
for finding the best combinations between two sets of data. This graph can
show relationships between large amounts of data that might otherwise be
difficult to see. As in topographic maps, colors or patterns indicate areas
that have the same value. The colors do not mark the data series. The wire
frame format displays the data in black and white. The contour graph
formats provide a two-dimensional view of the data from above, similar to
a two-dimensional topographic map.
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Updating Data in an Existing Graph
If you need to format your graph in a way that is not supported by the graph
formatting VIs, you can insert the graph in a template, format the graph the
way you want, and use the Word Update Graph VI or the Excel Update
Graph VI to fill the graph with data. You can use these VIs to update
numerical data, row and column headers, or values and categories.

To specify the location of the graph that you want to update, transfer the
graph index number from the Inlineshapes or Shapes collection to the
graph index parameter.

Note Graphs, pictures, and OLE objects are members either of an Inlineshapes collection
in a Word document or a Shapes collection in an Excel worksheet. Each graph in one of
these collections accounts for one index value.

Formatting Graphs
You can use the VIs located on the Graphs and Pictures palettes of both
the Functions»Report Generation»Word Specific VIs and the
Functions»Report Generation»Excel Specific VIs palettes to format
existing graphs.

The Word Format Picture VI and the Excel Format Picture VI can set graph
size or change color type. Other Graph and Picture VIs can set color
attributes, modify scale, and set font attributes for existing graphs.

To specify the location of a graph that you want to format, transfer the graph
index number from the Inlineshapes or Shapes collection to the graph
index parameter.

Pie Pie graphs show the relationship or proportions of the parts to the whole. Pie
graphs are useful for emphasizing a significant element. A pie graph always
contains one data series. If you select more than one data series when you
create a pie graph, only one data series displays. To display more than one
data series in a round graph format, use the doughnut graph type.

Area Area graphs show the relative importance of values over a period of time.
Although area graphs are similar to line graphs, area graphs emphasize the
amount of change or magnitude of values rather than time and the rate of
change.

Graph Type Description
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5
Executing VBA (Visual Basic)
Macros from LabVIEW

This chapter explains how to use the Report Generation Toolkit to execute
VBA (Microsoft Visual Basic) macros from LabVIEW into Microsoft
Word (hereafter known as Word) documents or Microsoft Excel (hereafter
known as Excel) workbooks. For Word documents, use the VIs located
on the Functions»Report Generation»Word Specific VIs»
Advanced»Macros palette. For Excel workbooks, use the VIs located on
the Functions»Report Generation»Word Specific VIs»Advanced»
Macros palette.

You can use the Word Run Macro VI and the Excel Run Macro VI to
execute VBA macros from LabVIEW. The VIs can run both existing VBA
macros and macros that you program to implement functionalities that the
Report Generation Toolkit does not support.

If the macro you want to execute requires input arguments, you can enter
them into the parameters input of the VI you are using. The data type for
this input is an array of variants. You must therefore convert all the input
parameters passed to the macro to variants and bundle the parameters
into an array. Use the To Variant function located on the Functions»
Advanced»Data Manipulation»Variant palette to convert the parameters
to variants. Use the Build Array function located on the Functions»Array
palette to build the parameters into an array.

If you need to retrieve an output value from a macro executed in LabVIEW,
you can find this value in the return value parameter of the Word Run
Macro VI or the Excel Run Macro VI. The output value is returned as a
variant. You must convert the value to LabVIEW-compatible data before
being used by LabVIEW. Use the Variant to Data function from the
Functions»Communication»ActiveX palette to convert the output value.

Note Word and Excel 2000 and Excel 97 support the ability to pass data to and from the
macro. Word 97 does not offer this feature.
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Before executing a macro from LabVIEW, make sure that the module in
which the macro is defined is present either in the VBA project associated
with the document or in the template on which the document is based,
for example, normal.dot.

If report generation starts from a Word or Excel template, you can import
the module containing the macro manually into the VBA project associated
with the template. Complete the following steps to import the module
manually.

1. Open the template in Word or Excel.

2. Select Tools»Macro»Visual Basic Editor.

3. In the project window of the Visual Basic editor, right-click the
template and select Import File from the shortcut menu.

4. Click the name of the file in which the macro is defined.

The Word Import Module VI and the Excel Import Module VI can also
import modules dynamically from LabVIEW. Using these two VIs, you can
import modules either from a *.bas file or from a LabVIEW string that
contains the module code source.

To run a macro that manipulates objects from another application, set a
reference to the application type library. This allows easy access to objects
that use either the Word Add Reference to VB Project VI or the Excel Add
Reference to VB Project VI. Refer to the Microsoft Visual Basic Help for
more information on type libraries.

The VI in the following illustration opens Word, creates a new document,
inserts a table into the document, adds a VBA module to the document,
executes the ProcessTable macro defined in this module, removes the
module from the document, and saves it.
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6
Customizing the
Report Generation Toolkit

This chapter explains how to develop and integrate custom tasks into
the Report Generation Toolkit. You can create your own VIs with
functionalities that are not available in the Report Generation Toolkit.

Working with ActiveX Automation
In this manual, ActiveX refers to the Microsoft ActiveX technology and
OLE technology. This technology is available only on Windows. Refer to
Chapter 18, ActiveX, of the LabVIEW User Manual for more information
about how LabVIEW works with ActiveX.

The Report Generation Toolkit has been designed around ActiveX
Automation technology. This technology is based on the Microsoft
Component Object Model (COM), which enables programs to interact
with one another. Automation allows LabVIEW to manipulate Word
and Excel objects. LabVIEW acts as an automation client that takes
control of the objects exposed by Microsoft Word (hereafter known as
Word) and Microsoft Excel (hereafter known as Excel), both of which are
automation servers.

The term object refers to any Word or Excel element that you can program,
manipulate, or control. Documents, cells, tables, and images are objects.
All these objects have properties and methods that you can access through
LabVIEW. Properties are characteristics of an object and methods are
actions that can be performed on an object. In Excel, for example, the Cell
object exposes the Font property and the Select method. In Word, the
Document object exposes the PageSetup property and the SaveAs method.

Complete the following steps to control Word or Excel from LabVIEW
using ActiveX automation.

1. Use the Automation Open function located on the Functions»
Communication»ActiveX palette to open a reference to either the
Word or Excel application.
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2. Use the Property and Invoke Nodes located on the Functions»
Communication»ActiveX palette to access and control all the objects
exposed by that application.

3. Use the Automation Close function located on the Functions»
Communication»ActiveX palette to release all the objects after the
application reference ends.

VI Architecture
The Report Generation Toolkit VIs are based on the LabVIEW Report
Generation VIs. The Report Generation Toolkit extends the Report Class
object to include some of the most frequently used Word and Excel objects.

The New Report VI opens a reference to either Word or Excel, depending
on the selected report type, and to a set of objects that are bundled into the
Report Class object. Objects include documents, tables, and Inlineshapes
in Word, and workbooks, worksheets, and Shapes for Excel.

When you use subsequent VIs, the Report Class object can extract Word
and Excel objects for modification by using LabVIEW property and invoke
nodes.

The VI in the following illustration obtains a reference to the Tables object
in Word, and invokes the Add method to add a new table into the document.

After report generation is complete, you can use the Dispose Report VI to
release all objects contained in the report class parameter.
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Developing Your Own VIs
You can use the Word VI Template VI and Excel VI Template VI to
develop your own report generation VIs. These template VIs consist of an
empty structure that you can customize to access Word and Excel objects,
set their properties, and invoke methods to implement new functionalities.

Note Do not save your own VIs into vi.lib. LabVIEW overwrites these libraries when
you upgrade.

You also can customize tasks with the Macro VIs. Refer to Chapter 5,
Executing VBA (Visual Basic) Macros from LabVIEW, for more
information about Microsoft Visual Basic macros.
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A
Technical Support Resources

Web Support
National Instruments Web support is your first stop for help in solving
installation, configuration, and application problems and questions. Online
problem-solving and diagnostic resources include frequently asked
questions, knowledge bases, product-specific troubleshooting wizards,
manuals, drivers, software updates, and more. Web support is available
through the Technical Support section of ni.com

NI Developer Zone
The NI Developer Zone at ni.com/zone is the essential resource for
building measurement and automation systems. At the NI Developer Zone,
you can easily access the latest example programs, system configurators,
tutorials, technical news, as well as a community of developers ready to
share their own techniques.

Customer Education
National Instruments provides a number of alternatives to satisfy your
training needs, from self-paced tutorials, videos, and interactive CDs to
instructor-led hands-on courses at locations around the world. Visit the
Customer Education section of ni.com for online course schedules,
syllabi, training centers, and class registration.

System Integration
If you have time constraints, limited in-house technical resources, or other
dilemmas, you may prefer to employ consulting or system integration
services. You can rely on the expertise available through our worldwide
network of Alliance Program members. To find out more about our
Alliance system integration solutions, visit the System Integration section
of ni.com
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Worldwide Support
National Instruments has offices located around the world to help address
your support needs. You can access our branch office Web sites from the
Worldwide Offices section of ni.com. Branch office Web sites provide
up-to-date contact information, support phone numbers, e-mail addresses,
and current events.

If you have searched the technical support resources on our Web site and
still cannot find the answers you need, contact your local office or National
Instruments corporate. Phone numbers for our worldwide offices are listed
at the front of this manual.
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Glossary

Prefix Meaning Value

m- milli- 10–3

k- kilo- 103

M- mega- 106

bookmark A placeholder in a Microsoft Word template from which you can insert text,
numbers, tables, or pictures.

Inlineshapes collection All the images, graphs, OLE objects, and lines in a Microsoft Word
document.

named range A placeholder in a Microsoft Excel template from which you can insert
text, numbers, tables, or pictures.

object A Microsoft Word or Excel element that you can program, manipulate, or
control using ActiveX automation.

Shapes collection All the images, graphs, and OLE objects in an Microsoft Excel worksheet.

workbook A Microsoft Excel file that consists of multiple worksheets.

worksheet A Microsoft Excel spreadsheet, part of a workbook file, in which you can
format and store data.
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Index

A
ActiveX Automation, 6-1 to 6-2
advanced VIs

Excel advanced VIs, 2-11
Word advanced VIs, 2-10

Append Control Image to Report VI, 2-6
Append Front Panel Image to Report VI, 2-6
Append Image to Report VI, 2-6
Append Report Text VI, 2-2
Append Table to Report VI, 2-3
Append Text to Report VI, 2-3
area graphs (table), 4-3

B
bar graphs (table), 4-2
bookmarks in Word, 3-1 to 3-3
Borders and Shading Constant (note), 2-8
borders and shading parameters (note), 2-8

C
column graphs (table), 4-2
conventions used in manual, vii
creating new reports, 2-1 to 2-2
customer education, A-1
customizing Report Generation Toolkit,

6-1 to 6-3
ActiveX Automation technology, 6-1 to 6-2
developing VIs, 6-3
VI architecture, 6-2

D
data

inserting
into Word reports, 2-2 to 2-3
into worksheets, 2-3

updating in existing graph, 4-3
documentation

conventions used in manual, vii
related documentation, vii-viii

E
Excel Add Reference to VB Project VI, 5-2
Excel Add Worksheet VI, 2-2
Excel Format Picture VI, 2-7, 4-3
Excel Get Data VI, 2-3
Excel Get Worksheet VI, 2-2
Excel Import Module VI, 5-2
Excel Insert Formula VI, 2-11
Excel Insert Graph VI, 4-1
Excel Insert Object VI, 2-11
Excel Rename Worksheet VI, 2-11
Excel reports

advanced VIs, 2-11
creating new reports, 2-1 to 2-2
formatting, 2-9 to 2-10
graphs, 4-1 to 4-3
inserting and formatting images, 2-6 to 2-7
inserting data into worksheets, 2-3
named ranges, 3-3 to 3-4
Visual Basic macros, 5-1 to 5-2

Excel Run Macro VI, 5-1
Excel Send Document VI, 2-11
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Excel Set Cell Alignment VI, 2-9
Excel Set Cell Color and Border VI, 2-9
Excel Set Cell Font VI, 2-9
Excel Set Format VI, 2-9
Excel Sort Data VI, 2-11
Excel VI Template VI, 6-3
Excel-specific VIs, 1-2

F
formatting

Excel reports, 2-9
graphs, 4-3
images

Excel reports, 2-6 to 2-7
Word reports, 2-6

Word reports, 2-8

G
graphs, 4-1 to 4-3

formatting, 4-3
inserting, 4-1 to 4-3
types of graphs supported (table),

4-2 to 4-3
updating data in existing graph, 4-3

H
high-level Report Generation VIs, 1-1

I
images, inserting and formatting

Excel reports, 2-6 to 2-7
Word reports, 2-6

Indent and Spacing Constant (note), 2-8
inserting data

Excel reports, 2-3
Word reports, 2-2 to 2-3

inserting images
Excel reports, 2-6 to 2-7
Word reports, 2-6

L
line graphs (table), 4-2

M
Microsoft Excel reports. See Excel reports.
Microsoft Visual Basic macros. See Visual

Basic macros.
Microsoft Word reports. See Word reports.

N
named ranges in Excel reports, 3-3 to 3-4
New Report VI, 2-1, 6-2
new reports, creating, 2-1 to 2-2
NI Developer Zone, A-1

P
pie graphs (table), 4-3

R
report generation. See Excel reports; Word

reports.
Report Generation palette, 1-1
Report Generation Toolkit

customizing, 6-1 to 6-3
ActiveX Automation technology,

6-1 to 6-2
developing VIs, 6-3
VI architecture, 6-2

functions overview, 1-1 to 1-2
overview, 1-1



Index

© National Instruments Corporation I-3 LabVIEW Report Generation Toolkit User Manual

S
Shapes collection in worksheets, 2-7
surface graphs (table), 4-2
system integration, by National

Instruments, A-1

T
tables in Word reports, 2-3 to 2-5

examples (figures), 2-5
guidelines, 2-4
Word-specific VIs, 2-3 to 2-4

technical support resources, A-1 to A-2
templates for reports

bookmarks in Word, 3-1 to 3-3
named ranges in Excel, 3-3 to 3-4

text, inserting into Word reports, 2-2 to 2-3
three-dimensional surface graphs (table), 4-2
To Variant function, 5-1

V
VIs

architecture of VIs, 6-2
developing your own VIs, 6-3
Excel-specific Report Generation

VIs, 1-2
high-level Report Generation VIs, 1-1
Word-specific Report Generation

VIs, 1-2
Visual Basic macros, 5-1 to 5-2

entering input arguments, 5-1
example (figure), 5-2
executing, 5-1
importing macro-containing module, 5-2
retrieving output values, 5-1

W
Web support from National Instruments, A-1
Word Add Document VI, 2-1

Word Add Reference to VB Project VI, 5-2
Word Easy Text VI, 2-2 to 2-3
Word Easy Title VI, 2-2
Word Edit Cell VI, 2-4, 3-2
Word Format Borders VI, 2-8
Word Format Cell VI, 2-4
Word Format Paragraph VI, 2-8
Word Format Picture VI, 2-6, 4-3
Word Format Table VI, 2-4
Word Format Text VI, 2-8
Word Get Document VI, 2-2
Word Import Module VI, 5-2
Word Insert Graph VI, 4-1
Word Insert Object VI, 2-10
Word Insert Row-Column-Cell VI, 2-4
Word Merge Cells VI, 2-4
Word reports

advanced VIs, 2-10
bookmarks, 3-1 to 3-3
creating new reports, 2-1 to 2-2
formatting, 2-8
graphs, 4-1 to 4-3
inserting and formatting images, 2-6
inserting data and text, 2-2 to 2-3
tables, 2-3 to 2-5
Visual Basic macros, 5-1 to 5-2

Word Run Macro VI, 5-1
Word Send Document VI, 2-10
Word Set Table Dimensions VI, 2-4
Word Table Borders and Shading VI, 2-4
Word VI Template VI, 6-3
Word-specific VIs

overview, 1-2
table editing and formatting, 2-3 to 2-4

Worldwide technical support, A-2

X
XY (scatter) graphs (table), 4-2
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